$re = '/([^_:]+):([^_]+)/m';
$str = 'TEST_firstname:john_lastname:doe_age:45';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);