import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "src=\"[^\"]*\\/kultpohod\\/userfiles\\/([^\"]*)\"[^>]*style=\"([^\"]*)";
final String string = "<img alt=\"\" src=\"/kultpohod/userfiles/file/2015/08/07/kappes.ru-5884a6f2b97671c68c024bebcb2b7531dc4b.jpg\" style=\"width: 500px; height: 375px;\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}