using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((?>[^)(]+|(?R))*\)";
string input = @"bla,blubb (x,(a,b(ruel,ps)),z) blubb.bla,bal (z,a)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}