re = /\((?>[^)(]+|(?R))*\)/
str = 'bla,blubb (x,(a,b(ruel,ps)),z) blubb.bla,bal (z,a)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end