#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-z])(?!\1{2})[a-z]{2}$"
Local $sString = "aab" & @CRLF & _
"aaa" & @CRLF & _
"aba" & @CRLF & _
"aZA" & @CRLF & _
"zzz" & @CRLF & _
"zxb" & @CRLF & _
"abcd" & @CRLF & _
"ab" & @CRLF & _
"xyz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")