$re = '/^([a-z])(?!\1{2})[a-z]{2}$/m';
$str = 'aab
aaa
aba
aZA
zzz
zxb
abcd
ab
xyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);