use strict;
my $str = '<foo/><boo/><woo/>';
my $regex = qr/(?<=>)(?=<)/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";