using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<[^>]*>)";
string substitution = @"$1\n";
string input = @"<foo/><boo/><woo/>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}