use strict;
my $str = '<foo/><boo/><woo/>';
my $regex = qr/(<[^>]*>)/p;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";