const regex = /\p{S}/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\p{S}', 'gi')
const str = `asdas�sadsad`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);