import re
regex = re.compile(r"\p{S}", flags=re.IGNORECASE)
test_str = "asdas�sadsad"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)