# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(rs\.Fields)\(([^()]*)\)(\s*=\s*)(rs\.Fields)\(([^()]*)\):/$1[$2].Value$3$4[$5].Value;/gm;t' <<< "rs.Fields(\"F1\") = rs.Fields(\"F2\"): "