// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(rs\.Fields)\(([^()]*)\)(\s*=\s*)(rs\.Fields)\(([^()]*)\):").unwrap();
let string = "rs.Fields(\"F1\") = rs.Fields(\"F2\"): ";
let substitution = "$1[$2].Value$3$4[$5].Value;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}