import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\/ \\[\\'administrator_start\\'\\])(.|\\n)*(\\/\\/ \\[\\'administrator_end\\'\\])";
final String string = " // ['administrator_start']\n"
+ " if ($_SESSION[\"user_group_short\"] == \"administrator\" && $_SESSION['active'] == 1) {\n"
+ "//\n"
+ "//\n"
+ "//Группа administrator\n"
+ "//\n"
+ "//\n"
+ " ?>\n"
+ " <div>\n"
+ " Администратор\n"
+ " </div>\n"
+ " <div id=\"databoard\">\n"
+ " <?php\n\n"
+ " function showTree($folder) {\n"
+ " /* Получаем полный список файлов и каталогов внутри $folder */\n"
+ " $files = scandir($folder);\n"
+ " foreach ($files as $file) {\n"
+ " /* Отбрасываем текущий и родительский каталог */\n"
+ " if (($file == '.') || ($file == '..')) {\n"
+ " continue;\n"
+ " }\n"
+ " $f0 = $folder . '/' . $file; //Получаем полный путь к файлу\n"
+ " /* Если это директория */\n"
+ " if (is_dir($f0)) {\n"
+ " /* Выводим, делая заданный отступ, название директории */\n"
+ " echo \"<p>\" . translate(iconv(mb_detect_encoding($file, mb_detect_order(), true), \"UTF-8\", $file)) . \"</p>\";\n"
+ " /* С помощью рекурсии выводим содержимое полученной директории */\n"
+ " showTree($f0);\n"
+ " } else {\n"
+ " /* Если это файл, то просто выводим название файла */\n"
+ " $name_page = explode(\".\", iconv(mb_detect_encoding($file, mb_detect_order(), true), \"UTF-8\", $file));\n"
+ " echo \"<a style='text-decoration: none;' href='\" . iconv(mb_detect_encoding($f0, mb_detect_order(), true), \"UTF-8\", $f0) . \"'>\" . translate($name_page[0]) . \"</a> \";\n"
+ " }\n"
+ " }\n"
+ " }\n\n"
+ " showTree(\"../pages/\" . $_SESSION['user_group_short']);\n"
+ " ?>\n"
+ " </div>\n"
+ " <?php\n"
+ " }\n"
+ "// ['administrator_end']\n"
+ "// ['insert_body']";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}