# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\/\/ \[\'administrator_start\'\])(.|\n)*(\/\/ \[\'administrator_end\'\])"
test_str = (" // ['administrator_start']\n"
" if ($_SESSION[\"user_group_short\"] == \"administrator\" && $_SESSION['active'] == 1) {\n"
"//\n"
"//\n"
"//Группа administrator\n"
"//\n"
"//\n"
" ?>\n"
" <div>\n"
" Администратор\n"
" </div>\n"
" <div id=\"databoard\">\n"
" <?php\n\n"
" function showTree($folder) {\n"
" /* Получаем полный список файлов и каталогов внутри $folder */\n"
" $files = scandir($folder);\n"
" foreach ($files as $file) {\n"
" /* Отбрасываем текущий и родительский каталог */\n"
" if (($file == '.') || ($file == '..')) {\n"
" continue;\n"
" }\n"
" $f0 = $folder . '/' . $file; //Получаем полный путь к файлу\n"
" /* Если это директория */\n"
" if (is_dir($f0)) {\n"
" /* Выводим, делая заданный отступ, название директории */\n"
" echo \"<p>\" . translate(iconv(mb_detect_encoding($file, mb_detect_order(), true), \"UTF-8\", $file)) . \"</p>\";\n"
" /* С помощью рекурсии выводим содержимое полученной директории */\n"
" showTree($f0);\n"
" } else {\n"
" /* Если это файл, то просто выводим название файла */\n"
" $name_page = explode(\".\", iconv(mb_detect_encoding($file, mb_detect_order(), true), \"UTF-8\", $file));\n"
" echo \"<a style='text-decoration: none;' href='\" . iconv(mb_detect_encoding($f0, mb_detect_order(), true), \"UTF-8\", $f0) . \"'>\" . translate($name_page[0]) . \"</a> \";\n"
" }\n"
" }\n"
" }\n\n"
" showTree(\"../pages/\" . $_SESSION['user_group_short']);\n"
" ?>\n"
" </div>\n"
" <?php\n"
" }\n"
"// ['administrator_end']\n"
"// ['insert_body']")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.