using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/).*(@.*)";
string input = @"https://athenea@bitbucket.org/athenea/hm_gui.git
http://athenea@bitbucket.org/athenea/hm_gui.git";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}