re = /(https?:\/\/).*(@.*)/m
str = 'https://athenea@bitbucket.org/athenea/hm_gui.git
http://athenea@bitbucket.org/athenea/hm_gui.git'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end