import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# Step 1: match all summary tags and skip them using recursive regexes !\n"
+ "(\n"
+ "<summary>\n"
+ " (?:\n"
+ " (?:(?!</?summary\\s*>)[\\s\\S])\n"
+ " |\n"
+ " (?1)\n"
+ " )*\n"
+ "</summary\\s*>\n"
+ ")\n"
+ "(*SKIP)(*FAIL)\n"
+ "|\n"
+ "# Step 2 : make sure the line doesn't start with bla or function\n"
+ "^(?!\\s*(?:function|bla)\\s*update)\n"
+ "# Step 3 : just match\n"
+ ".*?update.*";
final String string = "<summary>\n"
+ "update record 'djk'\n"
+ "</summary>\n\n"
+ "<tester>\n"
+ "function update record 'djk'\n"
+ "update record 'djk'\n"
+ "function method update record 'djk'\n"
+ " bla update\n"
+ "</tester>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}