re = /# Step 1: match all summary tags and skip them using recursive regexes !
(
<summary>
(?:
(?:(?!<\/?summary\s*>)[\s\S])
|
(?1)
)*
<\/summary\s*>
)
(*SKIP)(*FAIL)
|
# Step 2 : make sure the line doesn't start with bla or function
^(?!\s*(?:function|bla)\s*update)
# Step 3 : just match
.*?update.*/mix
str = '<summary>
update record \'djk\'
</summary>
<tester>
function update record \'djk\'
update record \'djk\'
function method update record \'djk\'
bla update
</tester>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end