package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.0*(\d+)@`)
var str = `123.00000000000080003027600003001002105002005001@asdsa`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}