re = /\.0*(\d+)@/
str = '123.00000000000080003027600003001002105002005001@asdsa'
# Print the match result
str.match(re) do |match|
puts match.to_s
end