package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([\w-]+\.)+[a-z]{2,}$`)
var str = `google.com.ua`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}