using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(00)+(?!0)";
string input = @"hello000world0000number00000100test00test20";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}