$re = '/(00)+(?!0)/';
$str = 'hello000world0000number00000100test00test20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);