import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a .*?<\\/a>";
final String string = "<a href=\"[nggallery id=xx]\"><span class=\"shutterset\"><img class=\"alignnone size-large wp-image-23067\" title=\"Image Title\" src=\"http://example.com/wp-content/uploads/2015/06/image-title.jpg\" alt=\"\" width=\"685\" height=\"456\" /></span></a>\n"
+ " \n"
+ "<a href=\"[nggallery id=xxxxx]\">Click here!</a>\n"
+ " \n"
+ "<a title=\"title title\" href=\"[nggallery id=xxx]\" target=\"_blank\">Title Link Title Link</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}