$re = '/<a .*?<\/a>/';
$str = '<a href="[nggallery id=xx]"><span class="shutterset"><img class="alignnone size-large wp-image-23067" title="Image Title" src="http://example.com/wp-content/uploads/2015/06/image-title.jpg" alt="" width="685" height="456" /></span></a>
<a href="[nggallery id=xxxxx]">Click here!</a>
<a title="title title" href="[nggallery id=xxx]" target="_blank">Title Link Title Link</a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);