package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^
<\d{4}>
\ (?>\\size{[^{}]*} )?
\K
.+?
(?=\\size{} (?:\\shake{\d}$)? | $)`)
var str = `// Resources for SEEN0001.TXT
#character '美佐枝'
#character '春原'
#character 'ボタン'
<0000> \{美佐枝}You little goblin...
<0001> Unable to contain her fury, Misae grabs both of Sunohara's legs...
<0002> \{春原}Heh?
<0003> ...and proceeds to use her killing move, The Giant Swing.
<0004> \{美佐枝}Uryaaaaaaaaaaaaaaaaaaa!
<0005> \{春原}Uwaaaaaaaaaaaaaah!
<0006> \{ボタン}Puhiiii.
<0007> \{春原}Uwaaaaaaaaaaah!
<0008> \{春原}Uwaaaaaaaaaaah!
<0009> \{春原}Uwaaaaaaaaaaah!
<0010> \{春原}Geeh!
<0171> \size{intA[1001]}*BOOM*\size{}\shake{4}
<0145> \size{intA[1001]}Dammit! Stupid rugby players!!\size{}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}