# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^
<\d{4}>
\ (?>\\size{[^{}]*} )?
\K
.+?
(?=\\size{} (?:\\shake{\d}$)? | $)
"""
test_str = ("// Resources for SEEN0001.TXT\n\n"
"#character '美佐枝'\n"
"#character '春原'\n"
"#character 'ボタン'\n\n"
"<0000> \\{美佐枝}You little goblin...\n"
"<0001> Unable to contain her fury, Misae grabs both of Sunohara's legs...\n"
"<0002> \\{春原}Heh?\n"
"<0003> ...and proceeds to use her killing move, The Giant Swing.\n"
"<0004> \\{美佐枝}Uryaaaaaaaaaaaaaaaaaaa!\n"
"<0005> \\{春原}Uwaaaaaaaaaaaaaah!\n"
"<0006> \\{ボタン}Puhiiii.\n"
"<0007> \\{春原}Uwaaaaaaaaaaah!\n"
"<0008> \\{春原}Uwaaaaaaaaaaah!\n"
"<0009> \\{春原}Uwaaaaaaaaaaah!\n"
"<0010> \\{春原}Geeh!\n"
"<0171> \\size{intA[1001]}*BOOM*\\size{}\\shake{4}\n"
"<0145> \\size{intA[1001]}Dammit! Stupid rugby players!!\\size{}\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.