#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^.\n]++\n?[^.\n]*\.)(?:.*\(Reminder (\d*)\))?"
Local $sString = "L-I-F-123Dolor sit amet. (Reminder 3)" & @CRLF & _
"L-I-F-123 Dolor sit amet." & @CRLF & _
"L-I-F-123 Dolor sit amet. Lorem Ipsum." & @CRLF & _
"But these break :" & @CRLF & _
"" & @CRLF & _
"L-I-F-123 Dolor sit amet" & @CRLF & _
"L-I-F-123 Dolor sit amet. Lorem Ipsum" & @CRLF & _
"L-I-F-123 Dolor sit amet.(Lorem Ipsum)" & @CRLF & _
"L-I-F-123 Dolor sit amet.(Lorem Ipsum) (Reminder 3)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")