$re = '/^([^.\n]++\n?[^.\n]*\.)(?:.*\(Reminder (\d*)\))?/m';
$str = 'L-I-F-123Dolor sit amet. (Reminder 3)
L-I-F-123 Dolor sit amet.
L-I-F-123 Dolor sit amet. Lorem Ipsum.
But these break :
L-I-F-123 Dolor sit amet
L-I-F-123 Dolor sit amet. Lorem Ipsum
L-I-F-123 Dolor sit amet.(Lorem Ipsum)
L-I-F-123 Dolor sit amet.(Lorem Ipsum) (Reminder 3)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);