re = /<li>[^<]*[Ss]izes[^<]*<\/li>/m
str = '<ul><li>Option to add embroidered text personalization below design<br/>for only $1.00 per shirt and free setup</li><li>Men's Sizes: XS-6XL</li><li>Individually folded and bagged with size sticker for easy distribution</li><li>Ready to ship in 7 business days after art approval</li></ul>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end