using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z.\/]{7})(drivernet1-161017\/)([a-zA-Z\-]{1,100})";
string input = @"gcr.io/drivernet1-161017/management-portal";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}