package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z.\/]{7})(drivernet1-161017\/)([a-zA-Z\-]{1,100})`)
var str = `gcr.io/drivernet1-161017/management-portal`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}