using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{1,2}\-\d{1,2}\-\d{2,4}";
string input = @"1-1-18
01-01-2018
1-01-2018
01-1-2018
01-01-18
01-1-18
1-01-18
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}