import re
regex = re.compile(r"\d{1,2}\-\d{1,2}\-\d{2,4}", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("1-1-18\n"
"01-01-2018\n"
"1-01-2018\n"
"01-1-2018\n"
"01-01-18\n"
"01-1-18\n"
"1-01-18\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")