import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d(?:_*\\d){9}|\\+?\\d_*\\d[\\s\\-]?(?:_*\\d){8,11}|\\d[ -]?\\d{3}[ -]?\\d{3}[ -]?\\d{4}";
final String string = "<p>I am having issues with creating a custom dock in a standard image we use in 10.10.3</p>\\n\\n<p>I have a .pkg that runs during a deploy studio workflow that replaces the dock.plist file with the one that has it set up how I want it. The plist works and the dock has what I want but is adding the ibook, maps ,and photos as well and I don't want them there. </p>\\n\\n<p>I did a find for those app names and they do not show up in the plist. Why are they being added? </p>\\n\\n<p>I can add the plist file if needed.</p>\\n\\n<p>Thanks in advance </p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}