import re
regex = re.compile(r"\d(?:_*\d){9}|\+?\d_*\d[\s\-]?(?:_*\d){8,11}|\d[ -]?\d{3}[ -]?\d{3}[ -]?\d{4}")
test_str = "<p>I am having issues with creating a custom dock in a standard image we use in 10.10.3</p>\\n\\n<p>I have a .pkg that runs during a deploy studio workflow that replaces the dock.plist file with the one that has it set up how I want it. The plist works and the dock has what I want but is adding the ibook, maps ,and photos as well and I don't want them there. </p>\\n\\n<p>I did a find for those app names and they do not show up in the plist. Why are they being added? </p>\\n\\n<p>I can add the plist file if needed.</p>\\n\\n<p>Thanks in advance </p>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")