re = /(.*?\(\d+\, \d+\))/
str = 'ON TAPE (000012, 000013)
ON TAPE (000012, 000013)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end