using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?!(?:[^""]*""[^""]*"")*[^""]*$)";
string substitution = @"";
string input = @"""COURSE"",247,""28/4/2016 12:53 Europe/Brussels"",1,""Verschil tussen merk, product en leveranciersverantwoordelijke NL"",""Active Enro""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}