re = /,(?!(?:[^"]*"[^"]*")*[^"]*$)/
str = '"COURSE",247,"28/4/2016 12:53 Europe/Brussels",1,"Verschil tussen merk, product en leveranciersverantwoordelijke NL","Active Enro"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result