#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xA)(?=[a-zA-Z]+[0-9])" & @CRLF & _
"(?<password>[0-9A-Za-z]{6,})" & @CRLF & _
"$"
Local $sString = "abc123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")