$re = '/(?=[a-zA-Z]+[0-9])
(?<password>[0-9A-Za-z]{6,})
$/xA';
$str = 'abc123';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);