#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(([a-zA-Z]+)(?=(?:,\s*[^,\)]+)*\))"
Local $sString = "a> this is sample(abc) string" & @CRLF & _
"" & @CRLF & _
"b> this is sampleenter code here(abc, anything) string" & @CRLF & _
"" & @CRLF & _
"c> this is sample(abc, anything, can appear) string "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")