using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(([a-zA-Z]+)(?=(?:,\s*[^,\)]+)*\))";
string input = @"a> this is sample(abc) string
b> this is sampleenter code here(abc, anything) string
c> this is sample(abc, anything, can appear) string ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}