import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h1>[^<>]*<\\/h1>(*SKIP)(*F)|(\\bsample|text\\b)(?=[^>]*(?:<|$))";
final String string = "here is a sample text to test match <a href=\"sample.html\">text sample here</a> text sample here <h1>sample text i do not want to match :(</h1>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}