#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^DTSTART:(.+)$"
Local $sString = "BEGIN:VCALENDAR" & @CRLF & _
"PRODID:-//Google Inc//Google Calendar 70.9054//EN" & @CRLF & _
"VERSION:2.0" & @CRLF & _
"CALSCALE:GREGORIAN" & @CRLF & _
"METHOD:PUBLISH" & @CRLF & _
"X-WR-CALNAME:1. Bundesliga" & @CRLF & _
"X-WR-TIMEZONE:Europe/Berlin" & @CRLF & _
"X-WR-CALDESC:iCal-Spielplan mit allen Spielen der 1. Bundesliga 2013-2014 -" & @CRLF & _
" gratis abonnieren!" & @CRLF & _
"BEGIN:VEVENT" & @CRLF & _
"DTSTART:20150226T200500Z" & @CRLF & _
"DTEND:20150226T220500Z" & @CRLF & _
"DTSTAMP:20150227T073355Z" & @CRLF & _
"UID:jmgapu2jbqhsesbpjlfc495c90@google.com" & @CRLF & _
"CREATED:20141216T183608Z" & @CRLF & _
"DESCRIPTION:Europa League\, Zw.\n\nhttp://www.fussball-spielplan.de" & @CRLF & _
"LAST-MODIFIED:20150226T221219Z" & @CRLF & _
"LOCATION:" & @CRLF & _
"SEQUENCE:3" & @CRLF & _
"STATUS:CONFIRMED" & @CRLF & _
"SUMMARY:Sporting Lissabon - VfL Wolfsburg (0:0)" & @CRLF & _
"TRANSP:TRANSPARENT" & @CRLF & _
"END:VEVENT" & @CRLF & _
"BEGIN:VEVENT" & @CRLF & _
"DTSTART:20150226T180000Z" & @CRLF & _
"DTEND:20150226T200000Z" & @CRLF & _
"DTSTAMP:20150227T073355Z" & @CRLF & _
"UID:uorcsvdsc24f37frgm36f3sfak@google.com" & @CRLF & _
"CREATED:20141216T164808Z" & @CRLF & _
"DESCRIPTION:Europa League\, Zw.\n\nhttp://www.fussball-spielplan.de" & @CRLF & _
"LAST-MODIFIED:20150226T200016Z" & @CRLF & _
"LOCATION:Borussia-Park\, Mönchengladbach" & @CRLF & _
"SEQUENCE:3" & @CRLF & _
"STATUS:CONFIRMED" & @CRLF & _
"SUMMARY:Bor. Mönchengladbach - FC Sevilla (2:3)" & @CRLF & _
"TRANSP:TRANSPARENT" & @CRLF & _
"END:VEVENT" & @CRLF & _
"BEGIN:VEVENT" & @CRLF & _
"DTSTART:20150225T194500Z " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")