import re
regex = re.compile(r"^DTSTART:(.+)$", flags=re.MULTILINE)
test_str = ("BEGIN:VCALENDAR\n"
"PRODID:-//Google Inc//Google Calendar 70.9054//EN\n"
"VERSION:2.0\n"
"CALSCALE:GREGORIAN\n"
"METHOD:PUBLISH\n"
"X-WR-CALNAME:1. Bundesliga\n"
"X-WR-TIMEZONE:Europe/Berlin\n"
"X-WR-CALDESC:iCal-Spielplan mit allen Spielen der 1. Bundesliga 2013-2014 -\n"
" gratis abonnieren!\n"
"BEGIN:VEVENT\n"
"DTSTART:20150226T200500Z\n"
"DTEND:20150226T220500Z\n"
"DTSTAMP:20150227T073355Z\n"
"UID:jmgapu2jbqhsesbpjlfc495c90@google.com\n"
"CREATED:20141216T183608Z\n"
"DESCRIPTION:Europa League\\, Zw.\\n\\nhttp://www.fussball-spielplan.de\n"
"LAST-MODIFIED:20150226T221219Z\n"
"LOCATION:\n"
"SEQUENCE:3\n"
"STATUS:CONFIRMED\n"
"SUMMARY:Sporting Lissabon - VfL Wolfsburg (0:0)\n"
"TRANSP:TRANSPARENT\n"
"END:VEVENT\n"
"BEGIN:VEVENT\n"
"DTSTART:20150226T180000Z\n"
"DTEND:20150226T200000Z\n"
"DTSTAMP:20150227T073355Z\n"
"UID:uorcsvdsc24f37frgm36f3sfak@google.com\n"
"CREATED:20141216T164808Z\n"
"DESCRIPTION:Europa League\\, Zw.\\n\\nhttp://www.fussball-spielplan.de\n"
"LAST-MODIFIED:20150226T200016Z\n"
"LOCATION:Borussia-Park\\, Mönchengladbach\n"
"SEQUENCE:3\n"
"STATUS:CONFIRMED\n"
"SUMMARY:Bor. Mönchengladbach - FC Sevilla (2:3)\n"
"TRANSP:TRANSPARENT\n"
"END:VEVENT\n"
"BEGIN:VEVENT\n"
"DTSTART:20150225T194500Z \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")