#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iu)\{(if|foreach)[\s]*(.*?)[\s]*\}"
Local $sString = "{include file = "include/common/head.tpl" }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{include file = "include/common/header.default.tpl" }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{if $content['outer']['container']['centered'] }hvcenterContainer hvcenter long{/if}" & @CRLF & _
"" & @CRLF & _
"{if !$content['inner']['payment']['payout']}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{if isset($content['inner']['pType']) }{$content.inner.pType}{else}1{/if}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }31001001{/language}" & @CRLF & _
"{language data-case="title" }31001002{/language}" & @CRLF & _
"{language data-case="title" }31001003{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language}34012002{/language}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" data-sublang="31001001" }21000033{/language}" & @CRLF & _
"" & @CRLF & _
"{language}34012003{/language}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" data-sublang="31001002" }21000033{/language}" & @CRLF & _
"" & @CRLF & _
"{language}34012004{/language}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" data-sublang="31001003" }21000033{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }31002001{/language}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }31002002{/language}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }31002003{/language}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }31002004{/language}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }31002005{/language}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }31002006{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{if $content['inner']['pType'] == 3 && $content['inner']['step']['count']['software'] >= 3 }active{/if}" & @CRLF & _
"" & @CRLF & _
"{language}36000005{/language}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }32013010{/language}" & @CRLF & _
"" & @CRLF & _
"{language}34012005{/language}" & @CRLF & _
"" & @CRLF & _
"{include file = "include/project/auth.tpl" }" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }21000001{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{if $content['inner']['pType'] == 1 && $content['inner']['step']['count']['default'] >= 3 || $content['inner']['pType'] == 2 && $content['inner']['step']['count']['offer'] >= 3}active{/if}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }36000005{/language}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }32013003{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{include file = "include/project/text.tpl" }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }21000002{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{if $content['inner']['pType'] == 1 && $content['inner']['step']['count']['default'] >= 4 || $content['inner']['pType'] == 2 && $content['inner']['step']['count']['offer'] >= 4 }active{/if}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }36000005{/language}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }32013004{/language}" & @CRLF & _
"" & @CRLF & _
"{language}34012006{/language}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }23005003{/language}" & @CRLF & _
"" & @CRLF & _
"{$content.inner.comment}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }21000007{/language}" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }21000001{/language}" & @CRLF & _
"" & @CRLF & _
"{if $content['inner']['pType'] == 1 && $content['inner']['step']['count']['default'] >= 5 || $content['inner']['pType'] == 2 && $content['inner']['step']['count']['offer'] >= 5 || $content['inner']['pType'] == 3 && $content['inner']['step']['count']['software'] >= 4 }active{/if}{language}36000005{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }32013005{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language}34012007{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }23000005{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }30000003{/language}" & @CRLF & _
"{foreach $content.inner.sourceLanguage.array as $key => $value }" & @CRLF & _
"{$value}" & @CRLF & _
"{/foreach}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }23000006{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{if isset($content['inner']['category']['array']) && is_array($content['inner']['category']['array']) && count($content['inner']['category']['array']) > 0}" & @CRLF & _
"{foreach $content.inner.category.array as $key => $value }" & @CRLF & _
"{$value.name}" & @CRLF & _
"{/foreach}" & @CRLF & _
"{/if}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }23000007{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{if isset($content['inner']['targetLanguage']['array']) && is_array($content['inner']['targetLanguage']['array']) && count($content['inner']['targetLanguage']['array']) > 0}" & @CRLF & _
"{foreach $content.inner.targetLanguage.array as $key => $value }" & @CRLF & _
"{$value.name}" & @CRLF & _
"{/foreach}" & @CRLF & _
"{/if}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{if isset($content['inner']['projectLanguages']['array']) && is_array($content['inner']['projectLanguages']['array']) && count($content['inner']['projectLanguages']['array']) > 0}" & @CRLF & _
"{foreach $content.inner.projectLanguages.array as $key => $value }" & @CRLF & _
"{$value.name}" & @CRLF & _
"{/foreach}" & @CRLF & _
"{/if}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }21000001{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{if $content['outer']['status']['visibility'] || $content['outer']['status']['filter'] }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language}36000005{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }32013006{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language}34012008{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{include file = "include/project/filter.tpl" }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }21000007{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }21000001{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{/if}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }32013001{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Toplam kelime sayısı : {if isset($content['inner']['information']['count']['word']) }{$content.inner.information.count.word}{else}-{/if}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"{language data-case="title" }39002002{/language}{language data-case="title" }39002004{/language}" & @CRLF & _
"" & @CRLF & _
"{if isset($content['inner']['summary']['time']) }{$content.inner.summary.time}{else}-{/if}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }39002003{/language}{language data-case="title" }39002005{/language}" & @CRLF & _
"" & @CRLF & _
"{if isset($content['inner']['summary']['amount']['total']) }{$content.inner.summary.amount.total}{else}0{/if} " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }39002006{/language}" & @CRLF & _
"{if isset($content['inner']['summary']['amount']['text']['count']) }{$content.inner.summary.amount.text.count}{else}0{/if} " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }39002007{/language}" & @CRLF & _
"{if isset($content['inner']['summary']['amount']['discount']['count']) }{$content.inner.summary.amount.discount.count}{else}0{/if} " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }39002008{/language}" & @CRLF & _
"{if isset($content['inner']['summary']['amount']['tax']['count']) }{$content.inner.summary.amount.tax.count}{else}0{/if} " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }39002009{/language}" & @CRLF & _
"{if isset($content['inner']['summary']['amount']['gap']['count']) }{$content.inner.summary.amount.gap.count}{else}0{/if} " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }32013002{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language}39002010{/language} : -" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }39002011{/language}" & @CRLF & _
"" & @CRLF & _
"-" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }39002012{/language}" & @CRLF & _
"" & @CRLF & _
"-" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{if $content['outer']['status']['adress'] }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language}36000005{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }32013007{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{include file = "include/miscellaneous/adress.tpl" }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }21000001{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{/if}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language}36000005{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }32013012{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{include file = "include/project/creditcard.tpl" }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }21000001{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{if $content['inner']['payment']['status'] && isset($content['inner']['payment']['response']) }" & @CRLF & _
"" & @CRLF & _
"{$content.inner.payment.response}" & @CRLF & _
"" & @CRLF & _
"{/if}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language}36000005{/language}" & @CRLF & _
"" & @CRLF & _
"{include file = "include/miscellaneous/payment.tpl" }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language}36000005{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }32013013{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{$content.inner.message} " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }21000034{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{else}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }32013011{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language}34012010{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="first" data-variable="'{$content.inner.fileCount}'" }39002023{/language}" & @CRLF & _
" {language data-variable="'{$content.inner.information.count.word}'" }39002024{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="first" }39002006{/language}" & @CRLF & _
"{language data-variable="'{$content.inner.projectLanguages.count}'" }39002026{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{if $content['inner']['summary']['amount']['text']['status']}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="first" }39002006{/language}" & @CRLF & _
"{$content.inner.summary.amount.text.count} " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{/if}" & @CRLF & _
"" & @CRLF & _
"{if $content['inner']['summary']['amount']['discount']['status']}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="first" }39002007{/language}" & @CRLF & _
"{$content.inner.summary.amount.discount.count} " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{/if}" & @CRLF & _
"" & @CRLF & _
"{if $content['inner']['summary']['amount']['tax']['status']}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="first" }39002008{/language}" & @CRLF & _
"{$content.inner.summary.amount.tax.count} " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{/if}" & @CRLF & _
"" & @CRLF & _
"{if $content['inner']['summary']['amount']['gap']['status']}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="first" }39002009{/language}" & @CRLF & _
"{$content.inner.summary.amount.gap.count} " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{/if}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="first" }39002027{/language}" & @CRLF & _
"{$content.inner.summary.amount.total} " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{language data-case="title" }21000020{/language}" & @CRLF & _
"{language data-case="title" }21000021{/language}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{/if}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{include file = "include/common/footer.long.tpl" }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{include file = "include/common/foot.tpl" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")