# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{(if|foreach)[\s]*(.*?)[\s]*\}"
test_str = ("{include file = \"include/common/head.tpl\" }\n\n\n"
"{include file = \"include/common/header.default.tpl\" }\n\n\n"
"{if $content['outer']['container']['centered'] }hvcenterContainer hvcenter long{/if}\n\n"
"{if !$content['inner']['payment']['payout']}\n\n\n\n"
"{if isset($content['inner']['pType']) }{$content.inner.pType}{else}1{/if}\n\n"
"{language data-case=\"title\" }31001001{/language}\n"
"{language data-case=\"title\" }31001002{/language}\n"
"{language data-case=\"title\" }31001003{/language}\n\n\n"
"{language}34012002{/language}\n\n"
"{language data-case=\"title\" data-sublang=\"31001001\" }21000033{/language}\n\n"
"{language}34012003{/language}\n\n"
"{language data-case=\"title\" data-sublang=\"31001002\" }21000033{/language}\n\n"
"{language}34012004{/language}\n\n"
"{language data-case=\"title\" data-sublang=\"31001003\" }21000033{/language}\n\n\n\n"
"{language data-case=\"title\" }31002001{/language}\n\n"
"{language data-case=\"title\" }31002002{/language}\n\n"
"{language data-case=\"title\" }31002003{/language}\n\n"
"{language data-case=\"title\" }31002004{/language}\n\n"
"{language data-case=\"title\" }31002005{/language}\n\n"
"{language data-case=\"title\" }31002006{/language}\n\n\n"
"{if $content['inner']['pType'] == 3 && $content['inner']['step']['count']['software'] >= 3 }active{/if}\n\n"
"{language}36000005{/language}\n\n"
"{language data-case=\"title\" }32013010{/language}\n\n"
"{language}34012005{/language}\n\n"
"{include file = \"include/project/auth.tpl\" }\n\n"
"{language data-case=\"title\" }21000001{/language}\n\n\n"
"{if $content['inner']['pType'] == 1 && $content['inner']['step']['count']['default'] >= 3 || $content['inner']['pType'] == 2 && $content['inner']['step']['count']['offer'] >= 3}active{/if}\n\n"
"{language data-case=\"title\" }36000005{/language}\n\n"
"{language data-case=\"title\" }32013003{/language}\n\n\n"
"{include file = \"include/project/text.tpl\" }\n\n\n"
"{language data-case=\"title\" }21000002{/language}\n\n\n"
"{if $content['inner']['pType'] == 1 && $content['inner']['step']['count']['default'] >= 4 || $content['inner']['pType'] == 2 && $content['inner']['step']['count']['offer'] >= 4 }active{/if}\n\n"
"{language data-case=\"title\" }36000005{/language}\n\n"
"{language data-case=\"title\" }32013004{/language}\n\n"
"{language}34012006{/language}\n\n"
"{language data-case=\"title\" }23005003{/language}\n\n"
"{$content.inner.comment}\n\n"
"{language data-case=\"title\" }21000007{/language}\n\n"
"{language data-case=\"title\" }21000001{/language}\n\n"
"{if $content['inner']['pType'] == 1 && $content['inner']['step']['count']['default'] >= 5 || $content['inner']['pType'] == 2 && $content['inner']['step']['count']['offer'] >= 5 || $content['inner']['pType'] == 3 && $content['inner']['step']['count']['software'] >= 4 }active{/if}{language}36000005{/language}\n\n\n\n\n"
"{language data-case=\"title\" }32013005{/language}\n\n\n\n\n"
"{language}34012007{/language}\n\n\n\n\n\n\n\n\n\n"
"{language data-case=\"title\" }23000005{/language}\n\n\n\n\n"
"{language data-case=\"title\" }30000003{/language}\n"
"{foreach $content.inner.sourceLanguage.array as $key => $value }\n"
"{$value}\n"
"{/foreach}\n\n\n\n\n\n\n\n"
"{language data-case=\"title\" }23000006{/language}\n\n\n\n\n\n\n\n"
"{if isset($content['inner']['category']['array']) && is_array($content['inner']['category']['array']) && count($content['inner']['category']['array']) > 0}\n"
"{foreach $content.inner.category.array as $key => $value }\n"
"{$value.name}\n"
"{/foreach}\n"
"{/if}\n\n\n\n\n\n\n\n\n"
"{language data-case=\"title\" }23000007{/language}\n\n\n\n"
"{if isset($content['inner']['targetLanguage']['array']) && is_array($content['inner']['targetLanguage']['array']) && count($content['inner']['targetLanguage']['array']) > 0}\n"
"{foreach $content.inner.targetLanguage.array as $key => $value }\n"
"{$value.name}\n"
"{/foreach}\n"
"{/if}\n\n\n\n"
" \n\n\n\n\n\n\n\n\n\n"
"{if isset($content['inner']['projectLanguages']['array']) && is_array($content['inner']['projectLanguages']['array']) && count($content['inner']['projectLanguages']['array']) > 0}\n"
"{foreach $content.inner.projectLanguages.array as $key => $value }\n"
"{$value.name}\n"
"{/foreach}\n"
"{/if}\n\n\n\n\n\n\n\n\n"
"{language data-case=\"title\" }21000001{/language}\n\n\n\n\n\n\n\n"
"{if $content['outer']['status']['visibility'] || $content['outer']['status']['filter'] }\n\n\n"
"{language}36000005{/language}\n\n\n\n\n"
"{language data-case=\"title\" }32013006{/language}\n\n\n\n\n"
"{language}34012008{/language}\n\n\n\n"
"{include file = \"include/project/filter.tpl\" }\n\n\n\n\n\n\n"
"{language data-case=\"title\" }21000007{/language}\n\n\n"
"{language data-case=\"title\" }21000001{/language}\n\n\n\n\n\n"
"{/if}\n\n\n\n\n\n\n\n\n\n"
"{language data-case=\"title\" }32013001{/language}\n\n\n\n\n"
"Toplam kelime sayısı : {if isset($content['inner']['information']['count']['word']) }{$content.inner.information.count.word}{else}-{/if}\n\n\n\n\n\n\n"
" \n\n"
" \n"
"{language data-case=\"title\" }39002002{/language}{language data-case=\"title\" }39002004{/language}\n\n"
"{if isset($content['inner']['summary']['time']) }{$content.inner.summary.time}{else}-{/if}\n\n\n\n\n\n\n\n\n\n\n\n\n"
"{language data-case=\"title\" }39002003{/language}{language data-case=\"title\" }39002005{/language}\n\n"
"{if isset($content['inner']['summary']['amount']['total']) }{$content.inner.summary.amount.total}{else}0{/if} \n\n\n\n\n\n"
"{language data-case=\"title\" }39002006{/language}\n"
"{if isset($content['inner']['summary']['amount']['text']['count']) }{$content.inner.summary.amount.text.count}{else}0{/if} \n\n\n\n\n\n"
"{language data-case=\"title\" }39002007{/language}\n"
"{if isset($content['inner']['summary']['amount']['discount']['count']) }{$content.inner.summary.amount.discount.count}{else}0{/if} \n\n\n\n\n\n"
"{language data-case=\"title\" }39002008{/language}\n"
"{if isset($content['inner']['summary']['amount']['tax']['count']) }{$content.inner.summary.amount.tax.count}{else}0{/if} \n\n\n\n\n\n"
"{language data-case=\"title\" }39002009{/language}\n"
"{if isset($content['inner']['summary']['amount']['gap']['count']) }{$content.inner.summary.amount.gap.count}{else}0{/if} \n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n"
"{language data-case=\"title\" }32013002{/language}\n\n\n\n\n"
"{language}39002010{/language} : -\n\n\n\n\n\n\n\n\n\n"
"{language data-case=\"title\" }39002011{/language}\n\n"
"-\n\n\n\n\n\n\n\n\n\n\n\n"
"{language data-case=\"title\" }39002012{/language}\n\n"
"-\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n"
"{if $content['outer']['status']['adress'] }\n\n\n"
"{language}36000005{/language}\n\n\n\n\n"
"{language data-case=\"title\" }32013007{/language}\n\n\n\n"
"{include file = \"include/miscellaneous/adress.tpl\" }\n\n\n"
"{language data-case=\"title\" }21000001{/language}\n\n\n\n"
"{/if}\n\n\n\n\n\n\n"
"{language}36000005{/language}\n\n\n\n\n"
"{language data-case=\"title\" }32013012{/language}\n\n\n\n\n"
"{include file = \"include/project/creditcard.tpl\" }\n\n\n\n\n"
"{language data-case=\"title\" }21000001{/language}\n\n\n\n\n\n\n\n\n\n"
"{if $content['inner']['payment']['status'] && isset($content['inner']['payment']['response']) }\n\n"
"{$content.inner.payment.response}\n\n"
"{/if}\n\n\n\n\n\n\n"
"{language}36000005{/language}\n\n"
"{include file = \"include/miscellaneous/payment.tpl\" }\n\n\n\n\n\n\n\n\n\n\n\n"
"{language}36000005{/language}\n\n\n"
"{language data-case=\"title\" }32013013{/language}\n\n\n\n"
"{$content.inner.message} \n\n\n\n"
"{language data-case=\"title\" }21000034{/language}\n\n\n\n\n\n\n\n\n\n\n\n\n"
"{else}\n\n\n\n\n\n\n\n\n\n\n"
"{language data-case=\"title\" }32013011{/language}\n\n\n"
"{language}34012010{/language}\n\n\n\n\n\n\n\n\n"
"{language data-case=\"first\" data-variable=\"'{$content.inner.fileCount}'\" }39002023{/language}\n"
" {language data-variable=\"'{$content.inner.information.count.word}'\" }39002024{/language}\n\n\n\n\n\n"
"{language data-case=\"first\" }39002006{/language}\n"
"{language data-variable=\"'{$content.inner.projectLanguages.count}'\" }39002026{/language}\n\n\n\n"
"{if $content['inner']['summary']['amount']['text']['status']}\n\n\n"
"{language data-case=\"first\" }39002006{/language}\n"
"{$content.inner.summary.amount.text.count} \n\n\n"
"{/if}\n\n"
"{if $content['inner']['summary']['amount']['discount']['status']}\n\n\n"
"{language data-case=\"first\" }39002007{/language}\n"
"{$content.inner.summary.amount.discount.count} \n\n\n"
"{/if}\n\n"
"{if $content['inner']['summary']['amount']['tax']['status']}\n\n\n"
"{language data-case=\"first\" }39002008{/language}\n"
"{$content.inner.summary.amount.tax.count} \n\n\n"
"{/if}\n\n"
"{if $content['inner']['summary']['amount']['gap']['status']}\n\n\n"
"{language data-case=\"first\" }39002009{/language}\n"
"{$content.inner.summary.amount.gap.count} \n\n\n"
"{/if}\n\n\n\n"
"{language data-case=\"first\" }39002027{/language}\n"
"{$content.inner.summary.amount.total} \n\n\n\n"
"{language data-case=\"title\" }21000020{/language}\n"
"{language data-case=\"title\" }21000021{/language}\n\n\n"
"{/if}\n\n\n\n"
"{include file = \"include/common/footer.long.tpl\" }\n\n\n"
"{include file = \"include/common/foot.tpl\" }")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.