use strict;
my $str = 'Regular expressions can be a pain. This tool is designed to help developers learn, practice, and compose regular expressions.
## tests:
// should not match
youtube.com/embed/v=0EWbonj7f18
youtube.com/e/v=0EWbonj7f18
youtube.com/attribution_link?u=/embed/v=0EWbonj7f18
youtube.com/attribution_link?u=/e/v=0EWbonj7f18
hey guys go to youtube and v=thisweird video i found
i found a youtube video on 4chan /v/foobarbaz
but we work at youtu.be and /thisweird video
// short links
youtu.be/WijF8aivOo8
youtu.be/0EWbonj7f18
// mixed
youtube.com/user/sandervandoorntv/watch?v=WijF8aivOo8
youtube.com/user/sandervandoorntv/watch?v=WijF8aivOo8&feature=related
youtube.com/user/sandervandoorntv/watch?feature=related&v=WijF8aivOo8
youtube.com/watch?v=0EWbonj7f18
youtube.com/watch?feature=related&v=0EWbonj7f18
youtube.com/watch?v=0EWbonj7f18&feature=related
youtube.com/embed/watch?v=0EWbonj7f18
youtube.com/embed/watch?feature=related&v=0EWbonj7f18
youtube.com/embed/v/0EWbonj7f18
youtube.com/e/v/0EWbonj7f18
youtube.com/e/watch?v=0EWbonj7f18
youtube.com/e/watch?feature=related&v=0EWbonj7f18
// attribution link
youtube.com/attribution_link?u=/user/sandervandoorntv/watch?v=WijF8aivOo8
youtube.com/attribution_link?u=/user/sandervandoorntv/watch?v=WijF8aivOo8&feature=related
youtube.com/attribution_link?u=/user/sandervandoorntv/watch?feature=related&v=WijF8aivOo8
youtube.com/attribution_link?u=/watch?v=0EWbonj7f18
youtube.com/attribution_link?u=/watch?feature=related&v=0EWbonj7f18
youtube.com/attribution_link?u=/watch?v=0EWbonj7f18&feature=related
youtube.com/attribution_link?u=/embed/watch?v=0EWbonj7f18
youtube.com/attribution_link?u=/embed/watch?feature=related&v=0EWbonj7f18
youtube.com/attribution_link?u=/embed/v/0EWbonj7f18
youtube.com/attribution_link?u=/e/v/0EWbonj7f18
youtube.com/attribution_link?u=/e/watch?v=0EWbonj7f18
youtube.com/attribution_link?u=/e/watch?feature=related&v=0EWbonj7f18
The HiFi RegExp tool is 100% JavaScript using jQuery. This tool was created by New Media Campaigns, the team behind HiFi, a next-generation CMS for web designers, developers, and agencies. Enjoy!
';
my $regex = qr/(?:youtube\.com\/\S*(?:(?:\/e(?:mbed))?\/|watch\?(?:\S*?&?v\=))|youtu\.be\/)([a-zA-Z0-9_-]{6,11})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}